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RabbitMQ cannot be started after an upgrade of Lime CRM
Summary
After an upgrade of Lime CRM, the RabbitMQ service might either not be able to start or it might not be visible in the list of installed Windows services at all.
RabbitMQ is used for sending messages to other services about events happening in Lime CRM. It is also used for triggering asynchronous jobs, like text file imports.
Symptoms
This may give rise to several symptoms like imports not working, not being able to open documents, or not being able to update values.
Resolution
Remove Erlang and RabbitMQ from the server
1. Make sure that all Windows Management Console application (like windows event log, computer management etc.) are closed.
2. Uninstall Erlang
3. Uninstall RabbitMQ
4. Ensure that the RabbitMQ service is not visible in the Windows Services list. If it is, open a command prompt as admin and run
sc delete RabbitMQ
5. Ensure that the following directories are deleted:
C:\Program Files\erl5.10.4 C:\Program Files (x86)\Lundalogik\Lime Pro Server\Erlang C:\Program Files (x86)\RabbitMQ C:\Program Files (x86)\Lundalogik\Lime Pro Server\RabbitMQ %appdata%\rabbitmq %programdata%\lundalogik\rabbitmq
6. Remove all registry keys under (by clicking windows button + write “regedit” + enter)
HKLM/SOFTWARE/Ericsson/Erlang/ErlSrv
Reinstall
There are two ways to reinstall - either reinstall Lime CRM Server, or install Erlang and RabbitMQ manually.
Install Erlang/RabbitMQ Manually
1. Install Erlang by running
C:\Program Files (x86)\Lundalogik\Lime Pro Server\webserver\externals\otp_win64_R16B03-1.exe
2. Install RabbitMQ by running
C:\Program Files (x86)\Lundalogik\Lime Pro Server\webserver\externals\rabbitmq-server.exe (name may differ)
Cause
This may be caused by MMC applications, such as the event log viewer, computer management, or even task manager being open during an upgrade.
Affected products
Lime CRM Server 12
Questions?
Please contact our support team if you have questions regarding any of the above.